BDU:2019-03635: Уязвимость компонента demux/mkv/mkv.cpp программы-медиапроигрывателя VideoLAN VLC, позволяющая нарушителю оказать воздействие на целостность данных, получить несанкционированный доступ к защищаемой информации, а также вызвать отказ в обслуживании

Описание уязвимости Уязвимость компонента demux/mkv/mkv.cpp программы-медиапроигрывателя VideoLAN VLC связана с использованием после освобождения. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, оказать воздействие на целостность данных, получить несанкционированный доступ к защищаемой информации, а также вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения, VideoLAN organization, АО «Концерн ВНИИНС»
Наименование ПО Ubuntu, Debian GNU/Linux, VLC Media Player, ОС ОН «Стрелец» (запись в едином реестре российских программ №6177)
Версия ПО 18.04 LTS (Ubuntu), 9.0 (Debian GNU/Linux), 19.04 (Ubuntu), 10.0 (Debian GNU/Linux), 3.0.7.1 (VLC Media Player), 1.0 (ОС ОН «Стрелец»)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Canonical Ltd. Ubuntu 18.04 LTS Не указана
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0 Не указана
  • Canonical Ltd. Ubuntu 19.04 Не указана
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0 Не указана
  • АО «Концерн ВНИИНС» ОС ОН «Стрелец» 1.0 Не указана (запись в едином реестре российских программ №6177)
Тип ошибки Использование после освобождения
Идентификатор типа ошибки CWE-416
Класс уязвимости Уязвимость кода
Дата выявления 14.08.2019
Базовый вектор уязвимости
  • CVSS 2.0: AV:N/AC:M/Au:N/C:P/I:P/A:P
  • CVSS 3.0: AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8) Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)
Возможные меры по устранению уязвимости
Для VLC Media Player:
https://www.videolan.org/security/sb-vlc308.html

Для Debian:
Обновление программного обеспечения (пакета vlc) до 3.0.8-0+deb9u1 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/4131-1/

Для ОС ОН «Стрелец»: https://strelets.net/patchi-i-obnovleniya-bezopasnosti#kumulyativnoe-obnovlenie
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются