BDU:2022-07190: Уязвимость реализации методов PreparedStatement.setText() или PreparedStatement.setBytea() драйвера JDBC (PgJDBC) для подключения Java-программ к базе данных PostgreSQL, позволяющая нарушителю раскрыть защищаемую информацию

Описание уязвимости Уязвимость реализации методов PreparedStatement.setText() или PreparedStatement.setBytea() драйвера JDBC (PgJDBC) для подключения Java-программ к базе данных PostgreSQL связана с небезопасными временными файлами. Эксплуатация уязвимости может позволить нарушителю раскрыть защищаемую информацию
Вендор Сообщество свободного программного обеспечения, PostgreSQL Global Development Group
Наименование ПО Debian GNU/Linux, pgjdbc
Версия ПО
  • 10.0 (Debian GNU/Linux)
  • 11.0 (Debian GNU/Linux)
  • до 42.2.27 (pgjdbc)
  • до 42.3.8 (pgjdbc)
  • до 42.4.3 (pgjdbc)
  • до 42.5.1 (pgjdbc)
Тип ПО Операционная система, Сетевое средство, Прикладное ПО информационных систем, Сетевое программное средство
Операционные системы и аппаратные платформы
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 11.0
Тип ошибки Раскрытие информации, Небезопасные временные файлы
Идентификатор типа ошибки
Класс уязвимости Уязвимость архитектуры
Дата выявления 23.11.2022
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,6)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:

Для драйвера JDBC (PgJDBC):
https://github.com/pgjdbc/pgjdbc/security/advisories/GHSA-562r-vg33-8x8h

Для Debian GNU/Linux:
https://security-tracker.debian.org/tracker/CVE-2022-41946
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Несанкционированный сбор информации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данная уязвимость актуальна только для Unix-подобных систем.
Последние изменения