BDU:2022-06240: Уязвимость браузеров Firefox, Firefox ESR и почтового клиента Thunderbird, позволяющая нарушителю обойти ограничение безопасного контекста для файлов cookie с префиксом __Host и __Secure и перезаписать эти файлы

Описание уязвимости Уязвимость браузеров Firefox, Firefox ESR и почтового клиента Thunderbird связана с использованием файлов cookie с префиксами __Host и __Secure без валидации и проверки целостности. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, обойти ограничение безопасного контекста для файлов cookie с префиксом __Host и __Secure и перезаписать эти файлы
Вендор Red Hat Inc., Canonical Ltd., ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, ООО «Ред Софт», ФССП России, Mozilla Corp., АО "НППКТ"
Наименование ПО Red Hat Enterprise Linux, Ubuntu, Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, РЕД ОС (запись в едином реестре российских программ №3751), ОС ТД АИС ФССП России, Thunderbird, Mozilla Firefox, Mozilla Firefox ESR, ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 7 (Red Hat Enterprise Linux)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8 (Red Hat Enterprise Linux)
  • 10 (Debian GNU/Linux)
  • 20.04 LTS (Ubuntu)
  • 8.2 Extended Update Support (Red Hat Enterprise Linux)
  • 11 (Debian GNU/Linux)
  • 8.1 Update Services for SAP Solutions (Red Hat Enterprise Linux)
  • 8.4 Extended Update Support (Red Hat Enterprise Linux)
  • 7.3 (РЕД ОС)
  • 1.7 (Astra Linux Special Edition)
  • ИК6 (ОС ТД АИС ФССП России)
  • 9 (Red Hat Enterprise Linux)
  • до 102.3 (Thunderbird)
  • до 105 (Mozilla Firefox)
  • до 102.3 (Mozilla Firefox ESR)
  • до 2.6 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Элементы безопасности, Зависимость от cookie-файлов без проверки достоверности и целостности при принятии решения о безопасности
Идентификатор типа ошибки
Класс уязвимости Уязвимость архитектуры
Дата выявления 20.09.2022
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,1)
Возможные меры по устранению уязвимости
Установка обновлений из доверенных источников.
В связи со сложившейся обстановкой и введенными санкциями против Российской Федерации рекомендуется устанавливать обновления программного обеспечения только после оценки всех сопутствующих рисков.

Компенсирующие меры:
- использование средств антивирусной защиты с функцией контроля доступа к веб-ресурсам;
- контролируемый доступ в сеть Интернет – регламентация разрешенных сетевых ресурсов и соединений;
- запуск приложений от имени пользователя с минимальными возможными привилегиями в операционной системе;
- использование альтернативных веб-браузеров;
- применение систем обнаружения и предотвращения вторжений.

Использование рекомендаций:
Для программных продуктов Mozilla Corp.:
https://www.mozilla.org/en-US/security/advisories/mfsa2022-40/
https://www.mozilla.org/en-US/security/advisories/mfsa2022-41/
https://www.mozilla.org/en-US/security/advisories/mfsa2022-42/

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2022-40958

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2022-40958

Для Ubuntu:
https://ubuntu.com/security/notices/USN-5649-1

Для ОС ТД АИС ФССП России:
https://goslinux.fssp.gov.ru/2726972/

Для Ред ОС:
http://repo.red-soft.ru/redos/7.3c/x86_64/updates/
https://redos.red-soft.ru/support/secure/uyazvimosti/mnozhestvennye-uyazvimosti-thunderbird/

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения firefox-esr до версии 102.4.0esr+repack-1~deb10u1.osnova1

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения thunderbird до версии 1:102.4.0+repack-1~deb10u1.osnova1

Для ОС Astra Linux:
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se16-bulletin-20221220SE16

Для ОС Astra Linux Special Edition 1.7:
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-1221SE17MD
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Нарушение авторизации
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения