BDU:2022-06025: Уязвимость программной платформы Apache Struts, связанная с неверным управлением генерацией кода, позволяющая нарушителю выполнить произвольный код

Описание уязвимости Уязвимость программной платформы Apache Struts связана с неверным управлением генерацией кода при обработке атрибута includeParams. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код путем отправки специально созданного запроса
Вендор IBM Corp., Apache Software Foundation
Наименование ПО IBM Call Center for Commerce, Apache Struts
Версия ПО
  • 9.5.0 (IBM Call Center for Commerce)
  • 10.0 (IBM Call Center for Commerce)
  • от 2.0.0 до 2.3.14.2 (Apache Struts)
Тип ПО Прикладное ПО информационных систем, Сетевое программное средство
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Неверное управление генерацией кода (Внедрение кода)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 24.05.2013
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,6)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,1)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Apache Struts:
https://cwiki.apache.org/confluence/display/WW/S2-014

Для программных продуктов IBM Corp.:
https://www.ibm.com/blogs/psirt/security-bulletin-ibm-call-center-and-apache-struts-struts-upgrade-strategy-various-cves-see-below/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Инъекция
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения