BDU:2022-05982: Уязвимость SSH клиента и сервера сетевого фреймворка Twisted, связанная с копированием буфера без проверки входных данных, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость SSH клиента и сервера сетевого фреймворка Twisted связана с возможностью принятия бесконечного количества данных для идентификатора версии SSH. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, Glyph Lefkowitz, АО "НППКТ"
Наименование ПО Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, Twisted, ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 10 (Debian GNU/Linux)
  • 11 (Debian GNU/Linux)
  • 1.7 (Astra Linux Special Edition)
  • от 21.7.0 до 22.2.0 (Twisted)
  • 4.7 (Astra Linux Special Edition)
  • до 2.5.2 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Сетевое программное средство
Операционные системы и аппаратные платформы
Тип ошибки Копирование буфера без проверки размера входных данных (классическое переполнение буфера)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 24.12.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Для Twisted:
использование рекомендаций производителя: https://github.com/twisted/twisted/security/advisories/GHSA-rv6r-3f5q-9rgx

Для Debian:
использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2022-21716

Для ОС Astra Linux:
использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-1110SE17
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20220829SE16

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения twisted до версии 20.3.0-7+deb11u1

Для Astra Linux Special Edition 4.7: https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-1121SE47
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения