BDU:2022-05037: Уязвимость системы управления уязвимостями Rapid7 Nexpose, связанная с недостаточной защитой структуры запроса SQL, позволяющая нарушителю манипулировать операторами "ANY" и "OR" в SearchCriteria и внедрить код SQL

Описание уязвимости Уязвимость системы управления уязвимостями Rapid7 Nexpose связана с недостаточной защитой структуры запроса SQL. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, манипулировать операторами "ANY" и "OR" в SearchCriteria и внедрить код SQL
Вендор Rapid7 inc.
Наименование ПО Nexpose
Версия ПО
  • до 6.6.129
Тип ПО Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Непринятие мер по защите структуры запроса SQL (атаки типа \"внедрение SQL\")
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 31.05.2022
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
https://docs.rapid7.com/release-notes/nexpose/20220302/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Инъекция
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Исследователь: Алексей Соловьев (Positive Technologies)
Последние изменения