BDU:2022-04887: Уязвимость инструмента автоматизации развертывания приложений в Kubernetes ArgoCD, связанная с ошибками процедуры подтверждения подлинности сертификата, позволяющая нарушителю проводить спуфинг-атаки

Описание уязвимости Уязвимость инструмента автоматизации развертывания приложений в Kubernetes ArgoCD связана с ошибками процедуры подтверждения подлинности сертификата. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, проводить спуфинг-атаки
Вендор The Linux Foundation
Наименование ПО ArgoCD
Версия ПО
  • от 0.4.0 до 2.2.11
  • от 2.3.0 до 2.3.6
  • от 2.4.0 до 2.4.5
Тип ПО Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Неправильное подтверждение подлинности сертификата, Отсутствие проверки достоверности сертификата OpenSSL
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 12.07.2022
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,6)
Возможные меры по устранению уязвимости
Установка обновлений из доверенных источников.
В связи со сложившейся обстановкой и введенными санкциями против Российской Федерации рекомендуется устанавливать обновления программного обеспечения только после оценки всех сопутствующих рисков.

Обновление программного обеспечения до версий 2.2.11, 2.3.6, 2.4.5 и выше

Компенсирующие меры:
- установить поле oidc.config.rootCA в argocd-cm ConfigMap.
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует
Способ эксплуатации
  • Подмена при взаимодействии
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения