BDU:2021-06184: Уязвимость системы управления Moodle, связанная с ошибками управления генерации кода, позволяющая нарушителю выполнить произвольный код

Описание уязвимости Уязвимость системы управления Moodle связана с ошибками управления генерации кода. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код с помощью специально сформированного запроса
Вендор ООО «Ред Софт», Мартин Дугамас
Наименование ПО РЕД ОС (запись в едином реестре российских программ №3751), Мoodle
Версия ПО
  • 7.2 Муром (РЕД ОС)
  • от 3.9.0 до 3.9.11 (Мoodle)
  • от 3.10.0 до 3.10.8 (Мoodle)
  • от 3.11.0 до 3.11.4 (Мoodle)
Тип ПО Операционная система, Сетевое программное средство
Операционные системы и аппаратные платформы
Тип ошибки Неверное управление генерацией кода (Внедрение кода)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 16.11.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для РедОС:
http://repo.red-soft.ru/redos/7.2c/x86_64/updates/

Для Moodle:
https://moodle.org/mod/forum/discuss.php?d=429095
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Инъекция
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения