BDU:2021-05681: Уязвимость программных средств мониторинга состояния ПЛК Fuji Electric V-Server Lite и Tellus Lite V-Simulator, связанная с выходом операции записи за границы буфера в памяти, позволяющая нарушителю выполнить произвольный код или вызвать отказ в обслуживании

Описание уязвимости Уязвимость программных средств мониторинга состояния ПЛК Fuji Electric V-Server Lite и Tellus Lite V-Simulator связана с выходом операции записи за границы буфера в памяти при синтаксическом анализе V9-файлов в модуле V-Simulator. Эксплуатация уязвимости может позволить нарушителю выполнить произвольный код или вызвать отказ в обслуживании с помощью специально созданного вредоносного файла или специально созданной вредоносной веб-страницы
Вендор Fuji Electric
Наименование ПО V-Server Lite , Tellus Lite V-Simulator
Версия ПО
  • до 4.0.12.0 (V-Server Lite)
  • до 4.0.12.0 (Tellus Lite V-Simulator)
Тип ПО ПО программно-аппаратного средства
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 14.06.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
https://us-cert.cisa.gov/ics/advisories/icsa-21-299-01
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения