BDU:2021-05311: Уязвимость функции PM_io_parser::read_vertex() компонента Nef_2/PM_io_parser.h библиотеки алгоритмов вычислительной геометрии CGAL, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции PM_io_parser::read_vertex() компонента Nef_2/PM_io_parser.h библиотеки алгоритмов вычислительной геометрии CGAL связана с ошибкой разбора полигонов Nef. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Вендор ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, ООО «Юбитех», АО "НППКТ"
Наименование ПО Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, Cgal, UBLinux (запись в едином реестре российских программ №6874), ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 10.0 (Debian GNU/Linux)
  • до 5.2.-3 (Cgal)
  • до 21.01 (UBLinux)
  • до 2.6 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Чтение за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 21.03.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,3)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Cgal:
Использование рекомендаций производителя: https://talosintelligence.com/vulnerability_reports/TALOS-2020-1225

Для Debian:
Использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2020-28601

Для Astra Linux:
Использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se16-bulletin-20211008SE16

Для UBLinux:

https://security.ublinux.ru/CVE-2020-28601

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения cgal до версии 5.2-3
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения