BDU:2021-03965: Уязвимость программного пакета sevenz архиватора Apache Commons Compress, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость программного пакета sevenz архиватора Apache Commons Compress связана с ошибками при обработке параметров длины входных данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Red Hat Inc., Apache Software Foundation, АО «Концерн ВНИИНС»
Наименование ПО Red Hat Enterprise Linux , Apache Commons Compress , ОС ОН «Стрелец» (запись в едином реестре российских программ №6177)
Версия ПО
  • 7 (Red Hat Enterprise Linux)
  • 8 (Red Hat Enterprise Linux)
  • от 1.6 до 1.20 включительно (Apache Commons Compress)
  • 1.0 (ОС ОН «Стрелец»)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Неправильная обработка несоответствия параметра длины
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 13.07.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:

Для Apache Commons Compress:
https://commons.apache.org/proper/commons-compress/security-reports.html

Для Red Hat:
https://access.redhat.com/security/cve/cve-2021-35516

Для ОС ОН «Стрелец»: https://strelets.net/patchi-i-obnovleniya-bezopasnosti#08122021
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование ресурсами
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения