BDU:2021-03763: Уязвимость пакета cpython языка программирования Python, связанная с недостатками обработки HTTP-запросов, позволяющая нарушителю нарушить целостность данных или вызвать отказ в обслуживании

Описание уязвимости

Уязвимость пакета cpython языка программирования Python связана с недостатками обработки HTTP-запросов. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, нарушить целостность данных или вызвать отказ в обслуживании

Вендор

Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», Python Software Foundation, АО "НППКТ", АО «Концерн ВНИИНС»

Версия ПО

  • 9 (Debian GNU/Linux)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10 (Debian GNU/Linux)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • от 3.7.0 до 3.7.10 (Python)
  • от 3.8.0 до 3.8.8 (Python)
  • до 3.6.13 (Python)
  • от 3.9.0 до 3.9.2 (Python)
  • до 2.5 (ОСОН ОСнова Оnyx)
  • до 2.6 (ОСОН ОСнова Оnyx)
  • до 16.01.2023 (ОС ОН «Стрелец»)

Тип ПО

Операционная система, Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Тип ошибки

Непоследовательная интерпретация HTTP-запросов ('Контрабанда HTTP-запросов')

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

19.02.2021

Базовый вектор уязвимости

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,9)

Возможные меры по устранению уязвимости

Использование рекомендаций:
Для Python:
https://github.com/python/cpython/pull/24297

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2021-23336

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/pages/viewpage.action?pageId=47416144
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Для ОСОН Основа:
Обновление программного обеспечения python-django до версии 2:2.2.24-1~bpo10+1

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения python2.7 до версии 2.7.18-13.1osnova8u1

Для ОСОН ОСнова Оnyx:
Обновление программного обеспечения python3.7 до версии 3.7.3-2+deb10u3osnova9u3

Для ОС ОН «Стрелец»:
Обновление программного обеспечения python3.5 до версии 3.5.3-1+osnova10
Обновление программного обеспечения python2.7 до версии 2.7.13-2+osnova10

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Существует в открытом доступе

Способ эксплуатации

  • Исчерпание ресурсов

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения