BDU:2021-03603: Уязвимость функции DwaCompressor::Classifier::Classifier программного обеспечения для хранения изображений с широкими динамическими диапазоном яркости OpenEXR, связанная с ошибкой единичного смещения, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости

Уязвимость функции DwaCompressor::Classifier::Classifier программного обеспечения для хранения изображений с широкими динамическими диапазоном яркости OpenEXR связана с ошибкой единичного смещения. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании

Вендор

Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», Industrial Light & Magic, АО «Концерн ВНИИНС»

Версия ПО

  • 9 (Debian GNU/Linux)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10 (Debian GNU/Linux)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • до 2.4.1 (OpenEXR)
  • до 16.01.2023 (ОС ОН «Стрелец»)

Тип ПО

Операционная система, Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Тип ошибки

Ошибка единичного смещения

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

02.05.2020

Базовый вектор уязвимости

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)

Возможные меры по устранению уязвимости

Для OpenEXR:
Использование рекомендаций производителя: https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v2.4.1

Для Debian:
Использование рекомендаций производителя: https://security-tracker.debian.org/tracker/CVE-2020-11765

Для Astra Linux:
Использование рекомендаций производителя:
https://wiki.astralinux.ru/pages/viewpage.action?pageId=47416144
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Для ОС ОН «Стрелец»:
Обновление программного обеспечения openexr до версии 2.2.0-11+deb9u4

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Существует в открытом доступе

Способ эксплуатации

  • Манипулирование структурами данных

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения