BDU:2021-01494: Уязвимость диссектора ASN.1 BER анализатора трафика компьютерных сетей Wireshark, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость диссектора ASN.1 BER анализатора трафика компьютерных сетей Wireshark связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения, Fedora Project, ООО «РусБИТех-Астра», Wireshark team, АО "НППКТ"
Наименование ПО Ubuntu, Debian GNU/Linux, Fedora, Astra Linux Common Edition (запись в едином реестре российских программ №4433), Wireshark, Astra Linux Special Edition (запись в едином реестре российских программ №369), ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 29 (Fedora)
  • 19.04 (Ubuntu)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 30 (Fedora)
  • 10.0 (Debian GNU/Linux)
  • от 2.4.0 до 2.4.15 включительно (Wireshark)
  • от 2.6.0 до 2.6.9 включительно (Wireshark)
  • от 3.0.0 до 3.0.2 включительно (Wireshark)
  • 1.7 (Astra Linux Special Edition)
  • до 2.1 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Сетевое программное средство
Операционные системы и аппаратные платформы
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 24.06.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Wireshark:
Обновление программного обеспечения до 3.4.3-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета wireshark) до 2.6.20-0+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета wireshark) до 2.6.20-0+deb9u1 или более поздней версии
использование рекомендаций производителя: https://wiki.astralinux.ru/astra-linux-se17-bulletin-2021-1126SE17

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4133-1

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/Q4QVJALLGVVC7MBUT4B4SHQVDXGJKGI7/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JY52XAC2UNC4X4ZPIXYMK5SVXV2PO5I3/

Для ОСОН Основа:
Обновление программного обеспечения wireshark до версии 2.6.20-0+deb10u1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения