BDU:2021-01436: Уязвимость компонента time/posix-timers.c ядра операционной системы Linux, связанная с целочисленным переполнением значения, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость компонента time/posix-timers.c ядра операционной системы Linux связана с целочисленным переполнением значения. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра»
Наименование ПО Ubuntu, Linux, Debian GNU/Linux, Astra Linux Common Edition (запись в едином реестре российских программ №4433)
Версия ПО
  • 12.04 (Ubuntu)
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • до 4.17.3 включительно (Linux)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10.0 (Debian GNU/Linux)
  • 14.04 ESM (Ubuntu)
Тип ПО Операционная система
Операционные системы и аппаратные платформы
  • Canonical Ltd. Ubuntu 12.04 32-bit
  • Canonical Ltd. Ubuntu 16.04 LTS 32-bit
  • Canonical Ltd. Ubuntu 18.04 LTS
  • Сообщество свободного программного обеспечения Linux до 4.17.3 включительно
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
  • Canonical Ltd. Ubuntu 14.04 ESM
Тип ошибки Целочисленное переполнение или циклический сдвиг
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 02.07.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Низкий уровень опасности (базовая оценка CVSS 2.0 составляет 2,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Linux:
Обновление программного обеспечения до 4.18 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета linux-4.9) до 4.9.110-1~deb8u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета linux-4.9) до 4.9.110-1~deb8u1 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/3847-1/
https://usn.ubuntu.com/3847-2/
https://usn.ubuntu.com/3847-3/
https://usn.ubuntu.com/3848-1/
https://usn.ubuntu.com/3848-2/
https://usn.ubuntu.com/3849-1/
https://usn.ubuntu.com/3849-2/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения