BDU:2021-01415: Уязвимость драйвера drivers/staging/irda/net/af_irda.c ядра операционной системы Linux, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости

Уязвимость драйвера drivers/staging/irda/net/af_irda.c ядра операционной системы Linux связана с отсутствием освобождения ресурса после истечения действительного срока его эксплуатирования. Эксплуатация уязвимости может позволить нарушителю вызвать отказ в обслуживании

Вендор

Canonical Ltd., Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра»

Наименование ПО

Ubuntu, Debian GNU/Linux, Linux, Astra Linux Common Edition (запись в едином реестре российских программ №4433)

Версия ПО

  • 12.04 (Ubuntu)
  • 16.04 LTS (Ubuntu)
  • 9 (Debian GNU/Linux)
  • 18.04 LTS (Ubuntu)
  • 8.0 (Debian GNU/Linux)
  • до 4.17 (Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 14.04 ESM (Ubuntu)
  • 10 (Debian GNU/Linux)

Тип ПО

Операционная система

Операционные системы и аппаратные платформы

  • Canonical Ltd. Ubuntu 12.04 32-bit
  • Canonical Ltd. Ubuntu 16.04 LTS 32-bit
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9
  • Canonical Ltd. Ubuntu 18.04 LTS
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Linux до 4.17
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Canonical Ltd. Ubuntu 14.04 ESM
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10

Тип ошибки

Неосвобождение ресурса после истечения действительного срока его эксплуатирования

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

04.09.2018

Базовый вектор уязвимости

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,9)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)

Возможные меры по устранению уязвимости

Использование рекомендаций:
Для Linux:
Обновление программного обеспечения до 4.19 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета linux-4.9) до 4.19 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета linux-4.9) до 4.19 или более поздней версии

Для Ubuntu:
https://usn.ubuntu.com/3775-1/
https://usn.ubuntu.com/3775-2/
https://usn.ubuntu.com/3776-1/
https://usn.ubuntu.com/3776-2/
https://usn.ubuntu.com/3777-1/
https://usn.ubuntu.com/3777-2/
https://usn.ubuntu.com/3777-3/

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Данные уточняются

Способ эксплуатации

  • Исчерпание ресурсов

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения