BDU:2021-01389: Уязвимость функции finish_stab файла stabs.c набора средств разработки программ Binutils, связанная с выходом операции за допустимые границы буфера данных, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции finish_stab файла stabs.c набора средств разработки программ Binutils связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Вендор Canonical Ltd., GNU General Public License, Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», АО "НППКТ"
Наименование ПО Ubuntu, GNU Binutils, Debian GNU/Linux, Astra Linux Common Edition (запись в едином реестре российских программ №4433), ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 18.04 LTS (Ubuntu)
  • 2.30 (GNU Binutils)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10.0 (Debian GNU/Linux)
  • до 2.3 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Canonical Ltd. Ubuntu 18.04 LTS
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
Тип ошибки Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 13.04.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Binutils:
Обновление программного обеспечения до 2.35.1-7 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета binutils) до 2.35.1-7 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета binutils) до 2.35.1-7 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4336-1

Для ОСОН Основа:
Обновление программного обеспечения binutils до версии 2.31.1-16.osnova0u1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения