BDU:2021-01355: Уязвимость компонентов реализации протокола удалённого рабочего стола FreeRDP, связанная с чтением за допустимыми границами буфера данных, позволяющая нарушителю получить доступ к конфиденциальным данным, а также вызвать отказ в обслуживании

Описание уязвимости

Уязвимость компонентов реализации протокола удалённого рабочего стола FreeRDP связана с чтением за допустимыми границами буфера данных. Эксплуатация уязвимости позволяет нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, а также вызвать отказ в обслуживании

Вендор

Сообщество свободного программного обеспечения, Canonical Ltd., ООО «РусБИТех-Астра», Fedora Project, Free Software Foundation, Inc., АО "НППКТ", АО «Концерн ВНИИНС»

Версия ПО

  • 9 (Debian GNU/Linux)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10 (Debian GNU/Linux)
  • 31 (Fedora)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • 32 (Fedora)
  • 20.04 LTS (Ubuntu)
  • до 2.1.2 (FreeRDP)
  • до 2.1 (ОСОН ОСнова Оnyx)
  • до 16.01.2023 (ОС ОН «Стрелец»)

Тип ПО

Операционная система, Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Тип ошибки

Чтение за границами буфера

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

22.06.2020

Базовый вектор уязвимости

    CVSS 3.0: Вектор не задан

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)

Возможные меры по устранению уязвимости

Использование рекомендаций:
Для freerdp2:
Обновление программного обеспечения до 2.1.2 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета freerdp2) до 2.1.2+dfsg1-1 или более поздней версии
Использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81

Для Debian:
Обновление программного обеспечения (пакета freerdp2) до 2.1.2+dfsg1-1 или более поздней версии

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6Y35HBHG2INICLSGCIKNAR7GCXEHQACQ/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XOZLH35OJWIQLM7FYDXAP2EAUBDXE76V/

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4481-1

Для ОСОН Основа:
Обновление программного обеспечения freerdp2 до версии 2.3.0+dfsg1-2osnova2

Для ОС ОН «Стрелец»:
Обновление программного обеспечения freerdp2 до версии 2.3.0+dfsg1-2osnova1

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Данные уточняются

Способ эксплуатации

  • Манипулирование структурами данных

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения