BDU:2021-01326: Уязвимость функции static ptrdiff_t finderrfunc из src/lj_err.c компилятора LuaJIT языка программированя Lua, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции static ptrdiff_t finderrfunc из src/lj_err.c компилятора LuaJIT языка программированя Lua связана с чтением за допустимыми границами буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», Mike Pall, АО "НППКТ"
Наименование ПО Debian GNU/Linux, Astra Linux Common Edition (запись в едином реестре российских программ №4433), LuaJIT, ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10.0 (Debian GNU/Linux)
  • 2.1.0 beta1 (LuaJIT)
  • 2.1.0 beta2 (LuaJIT)
  • 2.1.0 beta3 (LuaJIT)
  • до 2.0.5 включительно (LuaJIT)
  • до 2.5 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
Тип ошибки Чтение за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 21.07.2020
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для luajit:
Обновление программного обеспечения до 2.0.4+dfsg-1+deb9u1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета luajit) до 2.0.4+dfsg-1+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета luajit) до 2.0.4+dfsg-1+deb9u1 или более поздней версии

Для ОСОН Основа:
Обновление программного обеспечения luajit до версии 2.1.0~beta3+dfsg-6osnova0u1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения