BDU:2021-01319: Уязвимость множества функций из mercurial/subrepo.py программного средства управления версиями Mercurial, позволяющая нарушителю нарушить целостность данных, а также вызвать отказ в обслуживании

Описание уязвимости Уязвимость множества функций из mercurial/subrepo.py программного средства управления версиями Mercurial связана с неверным определением ссылки перед доступом к файлу. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, нарушить целостность данных, а также вызвать отказ в обслуживании
Вендор Сообщество свободного программного обеспечения, Canonical Ltd., ООО «РусБИТех-Астра», Matt Mackall
Наименование ПО Debian GNU/Linux, Ubuntu, Astra Linux Common Edition (запись в едином реестре российских программ №4433), Mercurial
Версия ПО
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 19.04 (Ubuntu)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10.0 (Debian GNU/Linux)
  • до 4.9 (Mercurial)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • Canonical Ltd. Ubuntu 19.04
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
Тип ошибки Неверное определение ссылки перед доступом к файлу
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 22.04.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5,8)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,9)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для mercurial:
Обновление программного обеспечения до 4.9 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета mercurial) до 4.8.2-1+deb10u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета mercurial) до 4.8.2-1+deb10u1 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4086-1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения