BDU:2021-01299: Уязвимость функции ldb_wildcard_compare пакета программ сетевого взаимодействия Samba, связанная с ошибкой в обработке чисел, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции ldb_wildcard_compare пакета программ сетевого взаимодействия Samba связана с ошибкой в обработке чисел. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», Samba Team
Наименование ПО Ubuntu, Debian GNU/Linux, Astra Linux Common Edition (запись в едином реестре российских программ №4433), Samba
Версия ПО
  • 15.04 (Ubuntu)
  • 15.10 (Ubuntu)
  • 12.04 (Ubuntu)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 2.12 «Орёл» (Astra Linux Common Edition)
  • 10.0 (Debian GNU/Linux)
  • 14.04 ESM (Ubuntu)
  • до 4.1.22 (Samba)
  • до 4.2.7 (Samba)
  • до 4.3.3 (Samba)
Тип ПО Операционная система, Сетевое программное средство
Операционные системы и аппаратные платформы
  • Canonical Ltd. Ubuntu 15.04 ARM64
  • Canonical Ltd. Ubuntu 15.10 32-bit
  • Canonical Ltd. Ubuntu 12.04 32-bit
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • ООО «РусБИТех-Астра» Astra Linux Common Edition 2.12 «Орёл» (запись в едином реестре российских программ №4433)
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
  • Canonical Ltd. Ubuntu 14.04 ESM
Тип ошибки Ошибки, возникающие при обработке чисел
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 29.12.2015
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,3)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Samba:
Обновление программного обеспечения до 2:4.13.3+dfsg-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета samba) до 2:4.5.16+dfsg-1+deb9u3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета samba) до 2:4.5.16+dfsg-1+deb9u3 или более поздней версии

Для Ubuntu:
https://ubuntu.com/security/notices/USN-2855-1
https://ubuntu.com/security/notices/USN-2855-2
https://ubuntu.com/security/notices/USN-2856-1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения