BDU:2021-01143: Уязвимость функции compose_group_nonknockout_nonblend_isolated_allmask_common() (base/gxblend.c) набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости

Уязвимость функции compose_group_nonknockout_nonblend_isolated_allmask_common() (base/gxblend.c) набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript связана с разыменованием указателя NULL. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании

Вендор

Canonical Ltd., ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, Artifex Software Inc., АО «Концерн ВНИИНС»

Наименование ПО

Версия ПО

  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 10.0 (Debian GNU/Linux)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • 20.10 LTS (Ubuntu)
  • 9.50 (Ghostscript)
  • 1.0 (ОС ОН «Стрелец»)

Тип ПО

Операционная система, Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Тип ошибки

Разыменование указателя NULL

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

13.08.2020

Базовый вектор уязвимости

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Низкий уровень опасности (базовая оценка CVSS 3.0 составляет 3,7)

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Существует в открытом доступе

Способ эксплуатации

  • Манипулирование структурами данных

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения