BDU:2021-00809: Уязвимость функции _gcry_md_block_write (cipher / hash-common.c) криптографической библиотеки Libgcrypt, позволяющая нарушителю выполнить произвольный код

Описание уязвимости Уязвимость функции _gcry_md_block_write (cipher / hash-common.c) криптографической библиотеки Libgcrypt связана с записью за границы буфера памяти. Эксплуатация уязвимости может позволить нарушителю выполнить произвольный код
Вендор ООО «Юбитех», Werner Koch
Наименование ПО UBLinux (запись в едином реестре российских программ №6874), Libgcrypt
Версия ПО
  • 21.1 (UBLinux)
  • 2102 (UBLinux)
  • 1.9.0 (Libgcrypt)
Тип ПО Операционная система, Программное средство защиты
Операционные системы и аппаратные платформы
Тип ошибки Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 29.01.2021
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,2)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)
Возможные меры по устранению уязвимости
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения