BDU:2021-00096: Уязвимость модуля VideoBroadcaster :: AddOrUpdateSink браузера Firefox, позволяющая нарушителю получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании

Описание уязвимости Уязвимость модуля VideoBroadcaster :: AddOrUpdateSink браузера Firefox связана с использованием области памяти после её освобождения. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить доступ к конфиденциальным данным, нарушить их целостность, а также вызвать отказ в обслуживании
Вендор АО «НПО РусБИТех», Сообщество свободного программного обеспечения, Novell Inc., Mozilla Corp.
Наименование ПО Astra Linux, Debian GNU/Linux, OpenSUSE Leap, Firefox
Версия ПО
  • 1.6 «Смоленск» (Astra Linux)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 15.1 (OpenSUSE Leap)
  • 10.0 (Debian GNU/Linux)
  • 15.2 (OpenSUSE Leap)
  • до 78.0 (Firefox)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • АО «НПО РусБИТех» Astra Linux 1.6 «Смоленск»
  • Сообщество свободного программного обеспечения Debian GNU/Linux 8.0
  • Сообщество свободного программного обеспечения Debian GNU/Linux 9.0
  • Novell Inc. OpenSUSE Leap 15.1
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
  • Novell Inc. OpenSUSE Leap 15.2
Тип ошибки Использование после освобождения
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 09.07.2020
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,3)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Firefox:
Обновление программного обеспечения до 78.0 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета firefox) до 78.0 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета firefox) до 78.0 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения