BDU:2020-04085: Уязвимость программного обеспечения для СУБД SQLite, связанная с ошибками при обработке чисел, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость программного обеспечения для СУБД SQLite связана с ошибками при обработке чисел. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения, ООО «РусБИТех-Астра», Hipp, Wyrick & Company, Inc., Oracle Corp., АО "НППКТ"
Наименование ПО Ubuntu, Debian GNU/Linux, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), SQLite, MySQL Workbench, Astra Linux Special Edition (запись в едином реестре российских программ №369), ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 10.0 (Debian GNU/Linux)
  • 19.10 (Ubuntu)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • 3.30.1 (SQLite)
  • 20.04 LTS (Ubuntu)
  • до 8.0.19 включительно (MySQL Workbench)
  • 1.7 (Astra Linux Special Edition)
  • 4.7 (Astra Linux Special Edition)
  • до 2.5 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, СУБД, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Ошибки, возникающие при обработке чисел
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 12.09.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для SQLite:
Обновление программного обеспечения до 3.32.3-1 или более поздней версии

Для Debian/GNU Linux:
Обновление программного обеспечения (пакета sqlite3) до 3.31.1-5 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета sqlite3) до 3.31.1-5 или более поздней версии
Или:
использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-0819SE17
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0926SE47

Для Ubuntu:
https://ubuntu.com/security/notices/USN-4394-1

Для программных продуктов Oracle Corp.:
https://www.oracle.com/security-alerts/cpuapr2020.html

Для ОСОН Основа:
Обновление программного обеспечения sqlite3 до версии 3.36.0-2osnova0
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения