BDU:2020-01909: Уязвимость функции WriteTGAImage графического редактора GraphicsMagick, связанная с выходом операции за границы буфера в памяти, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции WriteTGAImage графического редактора GraphicsMagick, связана с выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании при помощи специально созданного файла изображения
Вендор Novell Inc., Canonical Ltd., ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, GraphicsMagick Group
Наименование ПО OpenSUSE Leap, Ubuntu, Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, SUSE Linux Enterprise Software Development Kit, SUSE Studio Onsite, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), GraphicsMagick
Версия ПО
  • 42.3 (OpenSUSE Leap)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 11 SP4 (SUSE Linux Enterprise Software Development Kit)
  • 15.0 (OpenSUSE Leap)
  • 1.3 (SUSE Studio Onsite)
  • 10.0 (Debian GNU/Linux)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • до 1.3.31 включительно (GraphicsMagick)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Выход операции за границы буфера в памяти, Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 17.12.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,3)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для graphicsmagick:
Обновление программного обеспечения до .4~hg15978-1+deb10u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2018-20184/

Для Ubuntu:
https://usn.ubuntu.com/4207-1/

Для Debian:
https://security-tracker.debian.org/tracker/CVE-2018-20184

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20210730SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20211019SE81
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения