BDU:2020-01816: Уязвимость функции archive_acl_from_text_lins библиотеки libarchive, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции archive_acl_from_text_lins библиотеки libarchive связана с разыменованием указателя NULL. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании при помощи специально созданного архива
Вендор Fedora Project, ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, Red Hat Inc., Novell Inc., АО "НППКТ"
Наименование ПО Fedora, Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, Red Hat Enterprise Linux, SUSE Linux Enterprise Module for Basesystem, OpenSUSE Leap, SUSE Linux Enterprise Module for Development Tools, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), libarchive, ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 28 (Fedora)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 29 (Fedora)
  • 8 (Red Hat Enterprise Linux)
  • 15 (SUSE Linux Enterprise Module for Basesystem)
  • 15 SP1 (SUSE Linux Enterprise Module for Basesystem)
  • 15.0 (OpenSUSE Leap)
  • 15 (SUSE Linux Enterprise Module for Development Tools)
  • 15 SP1 (SUSE Linux Enterprise Module for Development Tools)
  • 30 (Fedora)
  • 10.0 (Debian GNU/Linux)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • от 3.3.0 до 3.4.0 (libarchive)
  • до 2.4.3 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Разыменование указателя NULL
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 20.12.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 6,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для libarchive:
Обновление программного обеспечения до 3.1.2-11+deb8u3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета libarchive) до 3.1.2-11+deb8u3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета libarchive) до 3.1.2-11+deb8u3 или более поздней версии

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2018-1000879/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2018-1000879

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CBOCC2M6YGPZA6US43YK4INPSJZZHRTG/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/W645KCLWFDBDGFJHG57WOVXGE62QSIJI/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZVXA7PHINVT6DFF6PRLTDTVTXKDLVHNF/

Для ОСОН Основа:
Обновление программного обеспечения libarchive до версии 3.4.3-2osnova1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения