BDU:2020-01752: Уязвимость в библиотеке для обработки и преобразования документов и фрагментов кода HTML/XML Ruby loofah, связанная с непринятием мер по защите структуры веб-страницы, позволяющая нарушителю оказать воздействие на целостность данных

Описание уязвимости Уязвимость в библиотеке для обработки и преобразования документов и фрагментов кода HTML/XML Ruby loofah связана с непринятием мер по защите структуры веб-страницы. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, оказать воздействие на целостность данных
Вендор ООО «РусБИТех-Астра», Novell Inc., Сообщество свободного программного обеспечения, Fedora Project, Red Hat Inc., Ruby Team
Наименование ПО Astra Linux Special Edition (запись в едином реестре российских программ №369), SUSE OpenStack Cloud, Debian GNU/Linux, SUSE Linux Enterprise High Availability, Fedora, Red Hat Software Collections, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), Ruby, CloudForms Management Engine, SUSE Storage
Версия ПО
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 7 (SUSE OpenStack Cloud)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 15 SP1 (SUSE Linux Enterprise High Availability)
  • 30 (Fedora)
  • 8 (SUSE OpenStack Cloud)
  • 6 (SUSE OpenStack Cloud)
  • 31 (Fedora)
  • - (Red Hat Software Collections)
  • 9 (SUSE OpenStack Cloud)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • до 2.3.0 включительно (Ruby)
  • 5 (CloudForms Management Engine)
  • 15 GA (SUSE Linux Enterprise High Availability)
  • 4 (SUSE Storage)
Тип ПО Операционная система, Прикладное ПО информационных систем, ПО виртуализации/ПО виртуального программно-аппаратного средства
Операционные системы и аппаратные платформы
Тип ошибки Непринятие мер по защите структуры веб-страницы (или \«Межсайтовая сценарная атака\»)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 22.10.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4,9)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,2)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Ruby:
Обновление программного обеспечения до 2.3.1+dfsg-1 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета ruby-loofah) до 2.2.3-1+deb10u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета ruby-loofah) до 2.2.3-1+deb10u1 или более поздней версии

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4WK2UG7ORKRQOJ6E4XJ2NVIHYJES6BYZ/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XMCWPLYPNIWYAY443IZZJ4IHBBLIHBP5/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2019-15587

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2019-15587/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Инъекция
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения