BDU:2020-01748: Уязвимость функции zipfileUpdate() системы управления базами данных SQLite, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции zipfileUpdate() системы управления базами данных SQLite связана с некорректной обработкой NULL-пути при обновлении zip-архива. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., ООО «РусБИТех-Астра», Red Hat Inc., Сообщество свободного программного обеспечения, Novell Inc., Hipp, Wyrick & Company, Inc., АО "НППКТ"
Наименование ПО Ubuntu, Astra Linux Special Edition (запись в едином реестре российских программ №369), Red Hat Enterprise Linux, Debian GNU/Linux, OpenSUSE Leap, SUSE Package Hub for SUSE Linux Enterprise, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), SQLite, ОСОН ОСнова Оnyx (запись в едином реестре российских программ №5913)
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • Desktop 6.0 (Red Hat Enterprise Linux)
  • Server 6.0 (Red Hat Enterprise Linux)
  • Workstation 6.0 (Red Hat Enterprise Linux)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 8 (Red Hat Enterprise Linux)
  • 15.1 (OpenSUSE Leap)
  • 12 SP3 (SUSE Package Hub for SUSE Linux Enterprise)
  • 12 (SUSE Package Hub for SUSE Linux Enterprise)
  • 19.10 (Ubuntu)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • до 3.30.1 включительно (SQLite)
  • 1.7 (Astra Linux Special Edition)
  • 4.7 (Astra Linux Special Edition)
  • до 2.1 (ОСОН ОСнова Оnyx)
Тип ПО Операционная система, Прикладное ПО информационных систем, СУБД
Операционные системы и аппаратные платформы
Тип ошибки Неограниченная загрузка файлов опасного типа
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 24.12.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для SQLite:
Обновление программного обеспечения до 3.31.1-3 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета sqlite3) до 3.16.2-5+deb9u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета sqlite3) до 3.16.2-5+deb9u1 или более поздней версии
Или:
использование рекомендаций производителя:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://wiki.astralinux.ru/astra-linux-se17-bulletin-2022-0819SE17
https://wiki.astralinux.ru/astra-linux-se47-bulletin-2022-0926SE47

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00010.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00015.html
https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00025.html

Для Ubuntu:
https://usn.ubuntu.com/4298-1/

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2019-19925

Для ОСОН Основа:
Обновление программного обеспечения sqlite3 до версии 3.27.2-3+deb10u1
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения