BDU:2020-01687: Уязвимость программного средства fence-agents, связанная с ошибками кодирования, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость программного средства fence-agents связана с ошибками кодирования. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Вендор Red Hat Inc., ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, Novell Inc.
Наименование ПО Red Hat Enterprise Linux, Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, OpenSUSE Leap, SUSE Linux Enterprise High Availability, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), SUSE Linux Enterprise Module for SUSE Manager Server, fence-agents
Версия ПО
  • 7 (Red Hat Enterprise Linux)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 8 (Red Hat Enterprise Linux)
  • 15.0 (OpenSUSE Leap)
  • 12 SP4 (SUSE Linux Enterprise High Availability)
  • 15 (SUSE Linux Enterprise High Availability)
  • 15 SP1 (SUSE Linux Enterprise High Availability)
  • 15.1 (OpenSUSE Leap)
  • 10.0 (Debian GNU/Linux)
  • 12 SP5 (SUSE Linux Enterprise High Availability)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • 4.0 (SUSE Linux Enterprise Module for SUSE Manager Server)
  • до 4.3.4 (fence-agents)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Ошибка кодирования
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 30.07.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 4)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 4,7)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для fence-agents :
Обновление программного обеспечения до 4.0.25-1+deb9u2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета fence-agents ) до 4.0.25-1+deb9u2 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета fence-agents ) до 4.0.25-1+deb9u2 или более поздней версии

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/CVE-2019-10153

Для программных продуктов Novell Inc.:
https://www.suse.com/security/cve/CVE-2019-10153/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения