BDU:2020-01633: Уязвимость функции exif_process_IFD_TAG интерпретатора языка программирования PHP, связанная с выходом операции за допустимые границы буфера данных, позволяющая нарушителю получить несанкционированный доступ к информации или вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции exif_process_IFD_TAG интерпретатора языка программирования PHP связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к информации или вызвать отказ в обслуживании
Вендор ООО «РусБИТех-Астра», Canonical Ltd., Novell Inc., Fedora Project, Сообщество свободного программного обеспечения, PHP Group
Наименование ПО Astra Linux Special Edition (запись в едином реестре российских программ №369), Ubuntu, OpenSUSE Leap, Fedora, Debian GNU/Linux, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), PHP
Версия ПО
  • 1.5 «Смоленск» (Astra Linux Special Edition)
  • 16.04 LTS (Ubuntu)
  • 42.3 (OpenSUSE Leap)
  • 18.04 LTS (Ubuntu)
  • 28 (Fedora)
  • 18.10 (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 29 (Fedora)
  • 12.04 ESM (Ubuntu)
  • 19.04 (Ubuntu)
  • 15.0 (OpenSUSE Leap)
  • 15.1 (OpenSUSE Leap)
  • 30 (Fedora)
  • 10.0 (Debian GNU/Linux)
  • 14.04 ESM (Ubuntu)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • от 7.1.0 до 7.1.29 (PHP)
  • от 7.2.0 до 7.2.18 (PHP)
  • от 7.3.0 до 7.3.5 (PHP)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 29.04.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для php5:
Обновление программного обеспечения до 5.6.40+dfsg-0+deb8u3 или более поздней версии

Для php7:
Обновление программного обеспечения до 7.0.33-0+deb9u5 или более поздней версии

Для php7.3:
Обновление программного обеспечения до 7.3.4-2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета php5.0) до 5.6.40+dfsg-0+deb8u3 или более поздней версии, (пакета php7.0) до 7.0.33-0+deb9u5 или более поздней версии, (пакета php7.3) до 7.3.9-1~deb10u1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета php5.0) до 5.6.40+dfsg-0+deb8u3 или более поздней версии, (пакета php7.0) до 7.0.33-0+deb9u5 или более поздней версии, (пакета php7.3) до 7.3.9-1~deb10u1 или более поздней версии

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2019-06/msg00010.html
https://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
https://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
https://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html

Для Fedora:
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2NFXYNCXZCPYT7ZN4ZLI5EPQQW44FRRO/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3BY2XUUAN277LS7HKAOGL4DVGAELOJV3/
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WN2HLPGEZEF4MFM5YC5FILZB5QEQFP3A/

Для Ubuntu:
https://usn.ubuntu.com/4009-1/
https://usn.ubuntu.com/3566-2/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения