BDU:2020-01414: Уязвимость функции exif_read_data интерпретатора PHP, связанная с выходом операции за допустимые границы буфера данных, позволяющая нарушителю получить несанкционированный доступ к информации или вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции exif_read_data интерпретатора PHP связана с выходом операции за допустимые границы буфера данных. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, получить несанкционированный доступ к информации или вызвать отказ в обслуживании
Вендор ООО «РусБИТех-Астра», Canonical Ltd., Сообщество свободного программного обеспечения, Novell Inc., PHP Group
Наименование ПО Astra Linux Special Edition (запись в едином реестре российских программ №369), Ubuntu, Debian GNU/Linux, OpenSUSE Leap, Astra Linux Special Edition для «Эльбрус» (запись в едином реестре российских программ №11156), PHP
Версия ПО
  • 1.5 «Смоленск» (Astra Linux Special Edition)
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 12.04 ESM (Ubuntu)
  • 19.04 (Ubuntu)
  • 15.0 (OpenSUSE Leap)
  • 10.0 (Debian GNU/Linux)
  • 14.04 ESM (Ubuntu)
  • 8.1 «Ленинград» (Astra Linux Special Edition для «Эльбрус»)
  • от 7.1.0 до 7.1.31 (PHP)
  • от 7.2.0 до 7.2.21 (PHP)
  • от 7.3.0 до 7.3.8 (PHP)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 27.06.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 9,3)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для php5:
Обновление программного обеспечения до 5.6.40+dfsg-0+deb8u3 или более поздней версии

Для php7:
Обновление программного обеспечения до 7.0.33-0+deb9u5 или более поздней версии

Для php7.3:
Обновление программного обеспечения до 7.3.4-2 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета php5.0) до 5.6.40+dfsg-0+deb8u3 или более поздней версии, (пакета php7.0) до 7.0.33-0+deb9u5 или более поздней версии, (пакета php7.3) до 7.3.9-1~deb10u1 или более поздней версии

Для Astra Linux:
https://wiki.astralinux.ru/astra-linux-se16-bulletin-20200327SE16
https://wiki.astralinux.ru/astra-linux-se81-bulletin-20200429SE81
https://wiki.astralinux.ru/astra-linux-se15-bulletin-20201201SE15

Для программных продуктов Novell Inc.:
https://lists.opensuse.org/opensuse-security-announce/2019-10/msg00019.html

Для Ubuntu:
https://usn.ubuntu.com/4097-1/
https://usn.ubuntu.com/4097-2/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения