BDU:2019-03615: Уязвимость почтового клиента Thunderbird и браузеров Firefox и Firefox ESR, связанная с ошибками экранирования символа каретки("^"), позволяющая нарушителю нарушить целостность данных

Описание уязвимости

Уязвимость почтового клиента Thunderbird и браузеров Firefox и Firefox ESR связана с ошибками экранирования символа каретки("^"). Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, нарушить целостность данных

Вендор

Red Hat Inc., Canonical Ltd., ООО «РусБИТех-Астра», Сообщество свободного программного обеспечения, Novell Inc., Mozilla Corp., АО «Концерн ВНИИНС»

Наименование ПО

Red Hat Enterprise Linux, Ubuntu, Astra Linux Special Edition (запись в едином реестре российских программ №369), Debian GNU/Linux, OpenSUSE Leap, SUSE Package Hub for SUSE Linux Enterprise, Thunderbird, Firefox ESR, Firefox, ОС ОН «Стрелец» (запись в едином реестре российских программ №6177)

Версия ПО

  • 6 (Red Hat Enterprise Linux)
  • 7 (Red Hat Enterprise Linux)
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 18.10 (Ubuntu)
  • 1.6 «Смоленск» (Astra Linux Special Edition)
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • 19.04 (Ubuntu)
  • 8 (Red Hat Enterprise Linux)
  • 15.0 (OpenSUSE Leap)
  • 15.1 (OpenSUSE Leap)
  • 12 (SUSE Package Hub for SUSE Linux Enterprise)
  • до 60.8 (Thunderbird)
  • до 60.8 (Firefox ESR)
  • до 68 (Firefox)
  • 1.0 (ОС ОН «Стрелец»)

Тип ПО

Операционная система, Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Тип ошибки

Недостаточная проверка вводимых данных

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

23.07.2019

Базовый вектор уязвимости

Уровень опасности уязвимости

Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,3)

Возможные меры по устранению уязвимости

Использование рекомендаций:
Для thunderbird:

Обновление программного обеспечения до 1:60.8.0-1~deb8u1 или более поздней версии



Для firefox-esr:

Обновление программного обеспечения до 60.8.0esr-1~deb9u1 или более поздней версии



Для firefox:

Обновление программного обеспечения до 68.0.1-2 или более поздней версии



Для Debian:

Обновление программного обеспечения(пакета thunderbird) до 1:60.8.0-1~deb8u1 или более поздней версии, (пакета firefox) до 68.0.1-2 или более поздней версии,(пакета firefox-esr) до 60.8.0esr-1~deb9u1 или более поздней версии



Для Ubuntu:

https://usn.ubuntu.com/4054-1/
https://usn.ubuntu.com/4064-1/

Для Astra Linux:
Обновление программного обеспечения(пакета Thunderbird) до 1:60.8.0-1~deb8u1 или более поздней версии,(пакета Firefox) до 68.0.1-2 или более поздней версии, (пакета Firefox ESR) до 60.8.0esr-1~deb9u1 или более поздней версии

Для программных продуктов Novell Inc.:
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00055.html
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00058.html
http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00073.html
http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00009.html
http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00010.html

Для программных продуктов Red Hat Inc.:
https://access.redhat.com/security/cve/cve-2019-11717

Для ОС ОН «Стрелец»: https://strelets.net/patchi-i-obnovleniya-bezopasnosti#kumulyativnoe-obnovlenie

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Данные уточняются

Способ эксплуатации

  • Манипулирование ресурсами

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

Данные уточняются
Последние изменения