BDU:2019-02097: Уязвимость функции extract_status_code системы балансировки сетевого трафика Keepalived, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции extract_status_code (lib/html.c) системы балансировки сетевого трафика keepalived связанна с переполнением буфера в динамической памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., Сообщество свободного программного обеспечения
Наименование ПО Ubuntu, Keepalived
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 18.10 (Ubuntu)
  • 19.04 (Ubuntu)
  • до 1.23 (Keepalived)
Тип ПО Операционная система, ПО сетевого программно-аппаратного средства
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Переполнение буфера в куче
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 18.04.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Обновление Keepalived до 2.0.7 или более полной версии
Статус уязвимости Потенциальная уязвимость
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения