BDU:2019-00963: Уязвимость функции vout программного средства для взаимодействия с серверами curl, позволяющая нарушителю раскрыть защищаемую информацию и вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции vout (tool_msgstr.c) программного средства для взаимодействия с серверами curl связана с чтением за границами буфера памяти при переполнении буфера кучи. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, раскрыть защищаемую информацию или вызвать отказ в обслуживании
Вендор АО «НПО РусБИТех», Дэниел Стенберг, ООО «Ред Софт»
Наименование ПО Astra Linux, cURL, РЕД ОС
Версия ПО
  • 1.6 «Смоленск» (Astra Linux)
  • до 7.61.1 (cURL)
  • до 7.2 Муром (РЕД ОС)
  • 8.1 «Ленинград» (Astra Linux)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Чтение за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 18.07.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,1)
Возможные меры по устранению уязвимости
Для curl:
Обновление программного обеспечения до 7.61.1 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета curl) до 7.38.0-4+deb8u12 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета curl) до 7.38.0-4+deb8u12 или более поздней версии

Для РЕД ОС:
Обновление операционной системы до версии 7.2 Муром
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения