BDU:2019-00877: Уязвимость в коде «psi/zdevice2.c» набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript, связанная с ошибками типа JBIG2Decode, позволяющая нарушителю обойти установленный контроль доступа

Описание уязвимости Уязвимость в коде «psi/zdevice2.c» набора программного обеспечения для обработки, преобразования и генерации документов Ghostscript связана с ошибками типа JBIG2Decode. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, обойти установленный контроль доступа
Вендор Software in the Public Interest Inc., Artifex Software Inc.
Наименование ПО Debian GNU/Linux, Ghostscript
Версия ПО
  • 8.0 (Debian GNU/Linux)
  • 9.0 (Debian GNU/Linux)
  • до 9.26 (Ghostscript)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Доступ к ресурсу через несовместимые типы
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 14.11.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)
Возможные меры по устранению уязвимости
Для Ghostscript:
Обновление программного обеспечения до 9.26 или более поздней версии

Для Debian:
Обновление программного обеспечения (пакета ghostscript) до 9.06~dfsg-2+deb8u12 или более поздней версии
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Нарушение авторизации
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения