BDU:2019-00420: Уязвимость функции handle_eac3 фреймворка для работы с мультимедиа форматами FFmpeg, позволяющая нарушителю вызвать отказ в обслуживании или выполнить произвольный код

Описание уязвимости Уязвимость функции handle_eac3 («libavformat/movenc.c») фреймворка для работы с мультимедиа форматами FFmpeg связана с некорректной обработкой типов фреймов (всех, кроме EAC3_FRAME_TYPE_INDEPENDENT), которые имеют несколько независимых потоков, что может открыть доступ за границы разрешенной области памяти при преобразовании AVI-файла в MPEG4. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании или выполнить произвольный код с помощью специально созданного AVI-файла
Вендор АО «НПО РусБИТех», FFmpeg team
Наименование ПО Astra Linux, FFmpeg
Версия ПО
  • 1.6 «Смоленск» (Astra Linux)
  • 4.0.1 (FFmpeg)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Обработка данных
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 27.06.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 8,8)
Возможные меры по устранению уязвимости
Для FFmpeg:
Обновление программного обеспечения до 4.0.2 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета ffmpeg) до 7:3.2.11-1~deb9u1 или более поздней версии
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения