BDU:2018-01509: Уязвимость функции parse_arguments сервера rsyncd утилиты Rsync, позволяющая пользователю нарушить целостность данных

Описание уязвимости Уязвимость функции parse_arguments (options.c) сервера rsyncd утилиты Rsync связана с возможностью использования нескольких параметров protect-args, что позволяет нарушителям обойти существующие механизмы защиты. Эксплуатация уязвимости может позволить пользователю, действующему удаленно, нарушить целостность данных
Вендор АО «НПО РусБИТех», Wayne Davison
Наименование ПО Astra Linux, Rsync
Версия ПО
  • 1.5 «Смоленск» (Astra Linux)
  • до 3.1.3 (Rsync)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Сообщество свободного программного обеспечения Linux -
Тип ошибки Элементы безопасности
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 17.01.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Для Rsync:
Обновление программного обеспечения до 3.1.3 или более поздней версии

Для Astra Linux:
Обновление программного обеспечения (пакета Rsync) до 3.1.2-2.2 или более поздней версии
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Злоупотребление функционалом
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения