BDU:2018-00715: Уязвимость функции ext4_valid_block_bitmap ядра операционной системы Linux, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости

Уязвимость функции ext4_valid_block_bitmap (fs/ext4/balloc.c) ядра операционной системы Linux связана с чтением за границами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании с помощью специально сформированного образа файловой системы ext4

Вендор

Сообщество свободного программного обеспечения

Наименование ПО

Linux

Версия ПО

  • до 4.15.15 включительно

Тип ПО

Операционная система

Операционные системы и аппаратные платформы

Данные уточняются

Тип ошибки

Чтение за границами буфера

Идентификатор типа ошибки

Класс уязвимости

Уязвимость кода

Дата выявления

22.03.2018

Базовый вектор уязвимости

Уровень опасности уязвимости

Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)

Возможные меры по устранению уязвимости

Статус уязвимости

Подтверждена производителем

Наличие эксплойта

Данные уточняются

Способ эксплуатации

  • Манипулирование структурами данных

Способ устранения

Обновление программного обеспечения

Информация об устранении

Уязвимость устранена

Идентификаторы других систем описаний уязвимостей

Прочая информация

-
Последние изменения