BDU:2018-00605: Уязвимость обработчика FTP URI программного средства для взаимодействия с серверами cURL, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость обработчика FTP URI программного средства для взаимодействия с серверами cURL вызвана переполнением буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании
Вендор Red Hat Inc., Canonical Ltd., Сообщество свободного программного обеспечения, Дэниел Стенберг, Oracle Corp., ООО «Ред Софт»
Наименование ПО Red Hat Enterprise Linux, Ubuntu, Debian GNU/Linux, cURL, Enterprise Manager Ops Center, PeopleSoft Enterprise PeopleTools, HTTP Server, Communications WebRTC Session Controller, Communications Application Session Controller, Fujitsu M10-1, Fujitsu M10-4, Fujitsu M10-4S, Fujitsu M12-1, Fujitsu M12-2, Fujitsu M12-2S, OSS Support Tools, РЕД ОС
Версия ПО
  • Desktop 7 (Red Hat Enterprise Linux)
  • Workstation 7 (Red Hat Enterprise Linux)
  • Server 7 (Red Hat Enterprise Linux)
  • 12.04 LTS (Ubuntu)
  • 14.04 LTS (Ubuntu)
  • 16.04 LTS (Ubuntu)
  • 9 (Debian GNU/Linux)
  • 17.10 (Ubuntu)
  • от 7.21.0 до 7.58.0 включительно (cURL)
  • 12.2.2 (Enterprise Manager Ops Center)
  • 12.3.3 (Enterprise Manager Ops Center)
  • 8.55 (PeopleSoft Enterprise PeopleTools)
  • 8.56 (PeopleSoft Enterprise PeopleTools)
  • 8.57 (PeopleSoft Enterprise PeopleTools)
  • 12.2.1.3 (HTTP Server)
  • до 7.2 (Communications WebRTC Session Controller)
  • 3.7.1 (Communications Application Session Controller)
  • 3.8.0 (Communications Application Session Controller)
  • 8 (Debian GNU/Linux)
  • 7 (Debian GNU/Linux)
  • до XCP2361 (Fujitsu M10-1)
  • до XCP3070 (Fujitsu M10-1)
  • до XCP2361 (Fujitsu M10-4)
  • до XCP3070 (Fujitsu M10-4)
  • до XCP2361 (Fujitsu M10-4S)
  • до XCP3070 (Fujitsu M10-4S)
  • до XCP2361 (Fujitsu M12-1)
  • до XCP3070 (Fujitsu M12-1)
  • до XCP3070 (Fujitsu M12-2)
  • до XCP2361 (Fujitsu M12-2)
  • до XCP2361 (Fujitsu M12-2S)
  • до XCP3070 (Fujitsu M12-2S)
  • до 18.3 (OSS Support Tools)
  • до 7.2 Муром (РЕД ОС)
Тип ПО Операционная система, Прикладное ПО информационных систем, Сетевое программное средство, ПО программно-аппаратного средства, ПО сетевого программно-аппаратного средства
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 14.03.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,5)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения