BDU:2018-00221: Уязвимость функции ImportOldFormatStyles анализатора DOC-файлов офисного пакета Apache OpenOffice, позволяющая нарушителю выполнить произвольный код

Описание уязвимости Уязвимость функции ImportOldFormatStyles анализатора DOC-файлов офисного пакета Apache OpenOffice связана с записью данных за пределами буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании или выполнить произвольный код при помощи специально сформированного документа
Вендор The Document Foundation, Apache Software Foundation
Наименование ПО LibreOffice, Apache OpenOffice
Версия ПО
  • до 5.0.2 (LibreOffice)
  • до 4.1.4 (Apache OpenOffice)
Тип ПО Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Microsoft Corp. Windows .
  • Apple Inc. Mac OS .
  • Сообщество свободного программного обеспечения Linux -
  • Сообщество свободного программного обеспечения Debian GNU/Linux -
Тип ошибки Запись за границами буфера
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 26.10.2017
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,8)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
обновление пакета Libreoffice до более поздней версии
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения