BDU:2017-00131: Уязвимость встроенного программного обеспечения программируемого логического контроллера ОВЕН ПЛК110, позволяющая нарушителю вызвать отказ в обслуживании устройства

Описание уязвимости Уязвимость встроенного программного обеспечения программируемого логического контроллера ОВЕН ПЛК110 связана с отсутствием проверки длины сохраненного пароля при его загрузке из файла, что приводит к переполнению буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании (повреждение памяти, циклическая перезагрузка устройства) путем сохранения файла с паролем длиной более 32 символов
Вендор ООО «ОВЕН»
Наименование ПО Встроенное программное обеспечение программируемого логического контроллера ОВЕН ПЛК110
Версия ПО
  • до 0.3.64
Тип ПО ПО программно-аппаратного средства АСУ ТП
Операционные системы и аппаратные платформы
  • ООО «ОВЕН» Segger embOS 3.88 ARM32
Тип ошибки Копирование буфера без проверки размера входных данных (классическое переполнение буфера)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 22.08.2016
Базовый вектор уязвимости
    CVSS 3.0: Вектор не задан
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7)
Возможные меры по устранению уязвимости
Обновление встроенного программного обеспечения до версии 0.3.64 или выше
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует
Способ эксплуатации Данные уточняются
Способ устранения Данные уточняются
Информация об устранении Уязвимость устранена
Ссылки на источники
Данные уточняются
Идентификаторы других систем описаний уязвимостей
Данные уточняются
Прочая информация -
Последние изменения