BDU:2015-00375: Уязвимость программного обеспечения PHP, позволяющая удаленному злоумышленнику нарушить целостность и доступность защищаемой информации

Описание уязвимости

Уязвимость существует в gd_ctx.c компонента GD в PHP из-за присутствия в именах путей последовательностей %00. Эксплуатация данной уязвимости позволяет злоумышленникам, действующим удаленно, перезаписывать произвольные файлы при помощи специально сформированных входных данных, которые вызывают функцию imagegd, imagegd2, imagegif, imagejpeg, imagepng, imagewbmp или imagewebp.

Вендор

PHP Group

Наименование ПО

PHP

Версия ПО

  • от 5.4.0 до 5.4.32
  • от 5.5.0 до 5.5.16

Тип ПО

Прикладное ПО информационных систем

Операционные системы и аппаратные платформы

Данные уточняются

Тип ошибки

Данные уточняются

Идентификатор типа ошибки

    Класс уязвимости

    Данные уточняются

    Дата выявления

    27.08.2014

    Базовый вектор уязвимости

    Уровень опасности уязвимости

    Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)

    Возможные меры по устранению уязвимости

    Для устранения уязвимости необходимо установить последнюю версию продукта, соответствующую используемой платформе. Необходимую информацию можно получить по адресу:
    http://www.php.net/

    Статус уязвимости

    Потенциальная уязвимость

    Наличие эксплойта

    Данные уточняются

    Способ эксплуатации

    Данные уточняются

    Способ устранения

    Данные уточняются

    Информация об устранении

    Информация об устранении отсутствует

    Идентификаторы других систем описаний уязвимостей

    Прочая информация

    Данные уточняются
    Последние изменения