BDU:2019-03829: Уязвимость компонента string_vformat (string.c) почтового сервера Exim, позволяющая нарушителю вызвать отказ в обслуживании или выполнить произвольный код

Описание уязвимости Уязвимость компонента string_vformat (string.c) почтового сервера Exim связана с ошибками переполнения буфера. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать отказ в обслуживании или выполнить произвольный код
Вендор Fedora Project, Canonical Ltd., Сообщество свободного программного обеспечения, GNU General Public License
Наименование ПО Fedora, Ubuntu, Debian GNU/Linux, exim
Версия ПО
  • 29 (Fedora)
  • 19.04 (Ubuntu)
  • 30 (Fedora)
  • 10.0 (Debian GNU/Linux)
  • 31 (Fedora)
  • от 4.92 до 4.92.2 включительно (exim)
Тип ПО Операционная система, Сетевое программное средство
Операционные системы и аппаратные платформы
  • Fedora Project Fedora 29
  • Canonical Ltd. Ubuntu 19.04
  • Fedora Project Fedora 30
  • Сообщество свободного программного обеспечения Debian GNU/Linux 10.0
  • Fedora Project Fedora 31
Тип ошибки Копирование буфера без проверки размера входных данных (классическое переполнение буфера)
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 27.09.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация Данные уточняются
Последние изменения