BDU:2019-02874: Уязвимость функции bitrv2 (fft4g.c) аудиоредактора Sound eXchange, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции bitrv2 (fft4g.c) аудиоредактора Sound eXchange связана с выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, вызвать отказ в обслуживании
Вендор Canonical Ltd., Sound Exchange Project
Наименование ПО Ubuntu, Sound eXchange
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 19.04 (Ubuntu)
  • 14.4.2 (Sound eXchange)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 15.02.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5,5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Sound eXchange: https://sourceforge.net/p/sox/bugs/321/

Для Ubuntu:
https://usn.ubuntu.com/4079-1/
https://usn.ubuntu.com/4079-2/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения