BDU:2019-02872: Уязвимость функции lsx_make_lpf (effect_i_dsp.c) аудиоредактора Sound eXchange, позволяющая нарушителю вызвать отказ в обслуживании

Описание уязвимости Уязвимость функции lsx_make_lpf (effect_i_dsp.c) аудиоредактора Sound eXchange связана с целоцисленным переполнением. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код или вызвать отказ в обслуживании
Вендор Canonical Ltd., Sound Exchange Project
Наименование ПО Ubuntu, Sound eXchange
Версия ПО
  • 16.04 LTS (Ubuntu)
  • 18.04 LTS (Ubuntu)
  • 19.04 (Ubuntu)
  • 14.4.2 (Sound eXchange)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Целочисленное переполнение или циклический сдвиг
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 15.02.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Высокий уровень опасности (базовая оценка CVSS 2.0 составляет 7,1)
Средний уровень опасности (базовая оценка CVSS 3.0 составляет 5)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Sound eXchange: https://sourceforge.net/p/sox/code/ci/f70911261a84333b077c29908e1242f69d7439eb

Для Ubuntu:
https://usn.ubuntu.com/4079-1/
https://usn.ubuntu.com/4079-2/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения