BDU:2019-02871: Уязвимость функции pango_log2vis_get_embedding_levels библиотеки Pango, позволяющая нарушителю выполнить произвольный код

Описание уязвимости Уязвимость функции pango_log2vis_get_embedding_levels библиотеки Pango связана с выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, выполнить произвольный код
Вендор Canonical Ltd., The GNOME Project
Наименование ПО Ubuntu, Pango
Версия ПО
  • 19.04 (Ubuntu)
  • от 1.42.0 до 1.43.0 включительно (Pango)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 19.07.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
Для Pango: https://gitlab.gnome.org/GNOME/pango/blob/master/pango/pango-bidi-type.c
Для Ubuntu: https://usn.ubuntu.com/4081-1/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения