BDU:2019-01161: Уязвимость функций jio_snprintf и jio_vsnprintf виртуальной машины Eclipse OpenJ9, позволяющая нарушителю оказать воздействие на конфиденциальность, целостность и доступность защищаемой информации

Описание уязвимости Уязвимость функций jio_snprintf и jio_vsnprintf виртуальной машины Eclipse OpenJ9 связана с выходом операции за границы буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать переполнение буфера и оказать воздействие на конфиденциальность, целостность и доступность защищаемой информации
Вендор Eclipse Foundation
Наименование ПО Eclipse OpenJ9
Версия ПО
  • до 0.12.0
Тип ПО Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
Данные уточняются
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 21.01.2019
Базовый вектор уязвимости
Уровень опасности уязвимости Критический уровень опасности (базовая оценка CVSS 2.0 составляет 10)
Критический уровень опасности (базовая оценка CVSS 3.0 составляет 9,8)
Возможные меры по устранению уязвимости
Использование рекомендаций:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=543659
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения