BDU:2018-00879: Уязвимость компонента WebAssembly браузера Firefox, позволяющая нарушителю вызвать аварийное завершение работы приложения

Описание уязвимости Уязвимость компонента WebAssembly браузера Firefox вызвана переполнением буфера в памяти. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, вызвать аварийное завершение работы приложения
Вендор Canonical Ltd., Mozilla Corp.
Наименование ПО Ubuntu, Firefox
Версия ПО
  • 14.04 (Ubuntu)
  • 16.04 (Ubuntu)
  • 17.10 (Ubuntu)
  • до 58 (Firefox)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Canonical Ltd. Ubuntu 14.04
  • Canonical Ltd. Ubuntu 16.04
  • Canonical Ltd. Ubuntu 17.10
Тип ошибки Выход операции за границы буфера в памяти
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 23.01.2018
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 5)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Для Mozilla Firefox использование рекомендаций: https://www.mozilla.org/security/advisories/mfsa2018-02/
Для Ubuntu использование рекомендаций: https://usn.ubuntu.com/3544-1/
Статус уязвимости Подтверждена производителем
Наличие эксплойта Данные уточняются
Способ эксплуатации
  • Манипулирование структурами данных
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения