BDU:2018-00026: Уязвимость менеджера пакетов rubygems, существующая из-за недостаточной проверки входных данных, позволяющая нарушителю осуществить перезапись любого файла

Описание уязвимости Уязвимость менеджера пакетов rubygems существует из-за недостаточной проверки входных данных. Эксплуатация уязвимости может позволить нарушителю, действующему удалённо, осуществить перезапись любого файла
Вендор АО «НПО РусБИТех», Сообщество свободного программного обеспечения
Наименование ПО Astra Linux, rubygems
Версия ПО
  • 1.5 «Смоленск» (Astra Linux)
  • до 2.6.12 включительно (rubygems)
Тип ПО Операционная система, Прикладное ПО информационных систем
Операционные системы и аппаратные платформы
  • Сообщество свободного программного обеспечения Linux -
Тип ошибки Недостаточная проверка вводимых данных
Идентификатор типа ошибки
Класс уязвимости Уязвимость кода
Дата выявления 04.09.2017
Базовый вектор уязвимости
Уровень опасности уязвимости Средний уровень опасности (базовая оценка CVSS 2.0 составляет 6,4)
Высокий уровень опасности (базовая оценка CVSS 3.0 составляет 7,5)
Возможные меры по устранению уязвимости
Для rubygems:
Обновление программного обеспечения до более поздней версии

Для Astra Linux:
обновление программного обеспечения до 1.9.3.194-8.1+deb7u6 или более поздней версии
Статус уязвимости Подтверждена производителем
Наличие эксплойта Существует в открытом доступе
Способ эксплуатации
  • Манипулирование ресурсами
Способ устранения Обновление программного обеспечения
Информация об устранении Уязвимость устранена
Ссылки на источники
Идентификаторы других систем описаний уязвимостей
Прочая информация -
Последние изменения